TowRig.com

Go Back   Diesel Forum - Cummins, Duramax, Powerstroke & Towing Forums > General Tow Rig Forums > General Tow Rig Discussion
Register Blogs FAQ Members List Calendar Mark Forums Read

Sponsor
Reply
 
Thread Tools Display Modes
  #1  
Old Posted 11-30-2007, 03:50 PM
wasted wages wasted wages is offline
 
Join Date: Feb 2005
Posts: 72
Knock - Knock,,,UPDATE !!

I'll try posting this here.....

My 07 5.9 is louder at idle all of a sudden.

I cranked it up one afternoon and it had a dead cylinder,,it took about 1 minute for it to clear up and then seemed to be OK...I figured no big deal.

Several day's ( and a tank or two different fuel ) I noticed the engine was louder at idle and has a noticeable fuel knock (injector ??)
while accelerating up thru the gears,

The fuel knock is pretty consistant under light throttle, but when I shift to 5-6 gear or step down hard on the throttle,, the knock goes away and the engine pulls hard like normal...

It feels and sounds like the computer changes something at about half throttle or when the turbo begins to produce boost...the change is that noticeable..under light throttle while driving highway speed it rattles bad,,
but as I step on the throttle (just a little ) it quits just as the turbo starts to whine...

Took it to the stealership,,they claim they "can't reproduce customers complaint" and said there is nothing wrong...no fuel in the oil,,,,blah blah,blah...wanted to sell me an injector cleaning for $99.99..

any ideas or thoughts ???

another question...
Under light or no throttle is the wastegate open or closed ?

Last edited by wasted wages; 12-20-2007 at 11:01 AM.
Reply With Quote
  #2  
Old Posted 11-30-2007, 07:52 PM in reply to wasted wages's post "Knock - Knock,,,UPDATE !!"
gbuddenhagen gbuddenhagen is offline
 
Join Date: Jan 2007
Location: Galveston, Texas
Posts: 180
my truck does it too, 82000 miles makes all kinds of strange noises lately thought it was injector problems and dealer told me no its fine....i have noticed with different fuels(diesel) can make it more loud or quite...same sa my engine oil after 5000 miles starts to run rough and louder as well...i guess these diesels have a mind of their own....
Reply With Quote
  #3  
Old Posted 12-02-2007, 08:44 AM in reply to gbuddenhagen's post starting "my truck does it too, 82000 miles makes..."
Duluth Diesel's Avatar
Duluth Diesel Duluth Diesel is offline
 
Join Date: Oct 2007
Posts: 93
Ah, the classic "we can't find it" and then try to sell you the work they should do under warranty anyway. Try another dealership. Or keep using the same one and start telling them you're going to lemon law the sucker if they can't fix it. This is a warranty issue and you shouldn't have to pay a dime for the repair. Make them fix it. I think 3 strikes and you can lemon law it. Just threatening to do that will often make them magically "find" the problem and fix it.

Many dealerships like to find ways to either not warranty something or at least get you to pay out of pocket for it.

-Chuck
Reply With Quote
  #4  
Old Posted 12-06-2007, 08:11 AM in reply to Duluth Diesel's post starting "Ah, the classic "we can't find it" and..."
BLK07 BLK07 is offline
 
Join Date: May 2007
Location: Castroville, TX
Posts: 23
wasted wages....have you had any luck. my 07 with 18k miles does the same thing. this is my first cummins, didn't know if it was normal. thought about taking it in and seeing what the dealer has to say.
Reply With Quote
  #5  
Old Posted 12-09-2007, 03:53 PM in reply to BLK07's post starting "wasted wages....have you had any luck...."
wasted wages wasted wages is offline
 
Join Date: Feb 2005
Posts: 72
Update 12/09/07

No codes,

Took it to the dealer again...
This time they did not write it up,,they sent the tech out to ride with me.

Tech claims that cummins changed the number of holes in the injector tip from 8 to 5 and they can carbon up easier...still think it's a bunch of bull.

They suggested a flush again ( some kind of valvoline product ) to which I declined...( 34K miles,,,, come on.......)

He also stated that the injectors fire 3 times per stroke. 2 small injections to prechamber the main injection. True ?

I do know that the oil pressure is not affected,,no fuel in the oil,,the truck pulls hard and the engine does not miss a beat,,,just this damn rattle on light to part throttle as I row through the gears...then at highway speed if I start to roll onto the throttle there is a .5 second rattle before the boost comes up and then it goes away.

It seem like a fuel delivery / timing problem more than anything else...

I may take it back again and tell them to do the flush and if that fixes the problem I will pay for it..if not they change the injectors.

Cummins Southern Plains is not far from where I work,,,I may swing by there also and see if they will give me any info...
Reply With Quote
  #6  
Old Posted 12-09-2007, 06:47 PM in reply to wasted wages's post starting "Update 12/09/07 No codes, Took..."
rocknbronco's Avatar
rocknbronco rocknbronco is offline
 
Join Date: Mar 2005
Location: Flat Top Mtn,Tn
Posts: 1,436
Have you done anything with the computer as far as programers? Also from what they are suggesting from Valvoline is the Synpower Fuel Cleaner, recomended every 3K, it works well. I'm also wondering if a Finch catalist wouldnt hurt that issue either.
Reply With Quote
  #7  
Old Posted 12-14-2007, 08:42 AM in reply to rocknbronco's post starting "Have you done anything with the..."
wasted wages wasted wages is offline
 
Join Date: Feb 2005
Posts: 72
Bone stock---no programmers.



Well it finally bit the dust,,,it's running on 5 cylinders and 1's going along for the ride...

It's at the dealership now ...will update what they find....

Stay tuned.....



EDIT 12/18/07

spoke with the service dept today,,,only thing they could tell me so far is,, the tech has 1 injector and 6 terminal plugs on his work order.....

Last edited by wasted wages; 12-18-2007 at 12:40 PM.
Reply With Quote
  #8  
Old Posted 12-20-2007, 11:00 AM in reply to wasted wages's post starting "Bone stock---no programmers. ..."
wasted wages wasted wages is offline
 
Join Date: Feb 2005
Posts: 72
Well,,,I have my truck back and it runs smoother than the day I drove it off the lot. This is the best it has ever run,,,quiet,,smooth,,pulls hard and the mystery rattle at light throttle is gone.

Mileage went up 2.2 mpg.

The dealer did the following:

Ran flow test on the CP3 pump ( ? ) and the lift pump ( both OK )
Ran flow test on injector return flow ( was high )
Reflashed the computer,,,replaced all 6 injectors and crossover tubes,,replaced 6 connectors ( ? )
adjusted the valves,,
and replaced a frozen u-joint on the rear drive shaft.

All done under warranty N/C.
Reply With Quote
  #9  
Old Posted 12-20-2007, 01:13 PM in reply to wasted wages's post starting "Well,,,I have my truck back and it runs..."
BLK07 BLK07 is offline
 
Join Date: May 2007
Location: Castroville, TX
Posts: 23
Called dealer. Take it in on the 27th. See what happens.
Reply With Quote
  #10  
Old Posted 12-20-2007, 03:10 PM in reply to BLK07's post starting "Called dealer. Take it in on the 27th...."
wasted wages wasted wages is offline
 
Join Date: Feb 2005
Posts: 72
BLK07 -- you leavin' your Banks programmer hooked up when you take it in ?
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:55 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.